Urgent.News

What's breaking now, across thousands of outlets.

Tech

PHP2Shell: a practical patch and check guide for PHP servers

What happened PHP2Shell is the nickname for CVE-2026-109618 and CVE-2026-109619. On October 21, 2026, the PHP project shipped emergency releases, PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35, to fix two critical flaws that it says "can allow unauthenticated remote code execution" ( PHP security advisory ). The day before, PHP had given advance notice that both were rated CVSS v4.0 9.2. If you upgrade,…

The nickname for two critical vulnerabilities discovered in PHP servers is PHP2Shell. On October 21, 2026, the PHP project released emergency updates, including PHP 8.5.12, 8.4.27, 8.3.36, and 8.2.35, to address these flaws. These vulnerabilities, rated CVSS v4.0 9.2, allow unauthenticated remote code execution. The first flaw, CVE-2026-109618, enables RCE via out-of-memory corruption, which can occur during request handling.

The second flaw, CVE-2026-109619, involves RCE via stale global state. PHP advises all PHP installations, including PHP-FPM, Apache with mod_php, php-cgi, FrankenPHP, and LiteSpeed, to be vulnerable. The highest risk is associated with mod_php, where an unauthenticated attacker can exploit the vulnerability before any application code is executed.

PHP has not specified the affected versions or the release date for the patches. The impact of these vulnerabilities is extensive, affecting various PHP runtimes such as CLI, web runtime, Apache with mod_php, php-cgi, and FrankenPHP. Distributions and LTS vendors have received the patches in advance. Attackers are exploiting these vulnerabilities early, with attempts logged by Amazon and Cloudflare within days of the disclosure.

However, no confirmed code execution has been observed yet. The recommended steps to mitigate these vulnerabilities include upgrading to the latest PHP versions, restarting all PHP-related services, and disabling session upload progress. If upgrading is not possible, other temporary measures such as limiting memory usage and using a web application firewall (WAF) can provide additional protection.

Written by urgent.news from Dev.to's reporting — not their text. Machine-written — may contain errors; check the original before relying on it.

Also reported by 1 other outlet

Read the original at dev.to →

More in Tech

PHANTOM.EXE 👻 — The Spirit in the Machine

PHANTOM.EXE 👻 — The Spirit in the Machine Somewhere between the last line of code and the darkness behind the screen, something is waiting to answer.

  • PHANTOM.EXE is a haunted-terminal experience for Hacktoberfest AI Challenge
  • Retro-inspired terminal with atmospheric visual effects and spooky theme
  • Accessible via browser, uses HTML, CSS, JavaScript, and optional AI integration

LiteLLM 1.107.0 compromise: incident response guide

What happened The LiteLLM 1.107.0 compromise began on October 21, 2026, when a compromised litellm==1.107.0 was published to PyPI and to LiteLLM's container registries.

  • Compromised LiteLLM 1.107.0 released on PyPI and container registries
  • Attack chain lasted two hours, potentially accessing sensitive data
  • Response includes identifying and isolating affected packages

Always Set persist-credentials: false in actions/checkout

There's a default in actions/checkout\ that most teams never change — and that quietly leaves a GitHub token sitting in a readable file for every subsequent step in the job. The fix is one line.

  • Set persist-credentials to false in actions/checkout
  • Default action writes git credential config file
  • Deleting file after checkout prevents security risk

More from Friday 30 October →