{
  "id": 18560531,
  "title": "GHSA-47W9-6R3F-938G: GHSA-47w9-6r3f-938g: Authorization Bypass and Host Root Command Execution in Canonical LXD and Incus",
  "url": "https://urgent.news/2026/11/06/ghsa-47w9-6r3f-938g-ghsa-47w9-6r3f-938g-authorization-bypass-and-host",
  "topic": "tech",
  "section": "Tech",
  "published": "2026-11-06T20:30:50.000Z",
  "source": {
    "name": "Dev.to",
    "slug": "dev-to",
    "url": "https://dev.to/cverports/ghsa-47w9-6r3f-938g-ghsa-47w9-6r3f-938g-authorization-bypass-and-host-root-command-execution-in-232g"
  },
  "original_language": "en",
  "account": "A critical vulnerability has been discovered in Canonical LXD and LXC Incus, allowing authorized users within restricted projects to bypass security restrictions and execute arbitrary commands with root privileges on the underlying host operating system. The weakness arises due to a missing authorization and configuration validation error when restoring instance snapshots or importing backups containing prohibited low-level hypervisor hooks such as raw.lxc or raw.qemu. This can enable attackers to restore modified configurations within restricted projects, leading to potential container escape and host root command execution.\n\nThe vulnerability, identified as GHSA-47W9-6R3F-938G, has been assigned a CVSS score of 9.9, indicating its high severity. It affects various versions of Canonical LXD and LXC Incus, including LTS 4.0/5.0 series (up to 5.0.7), LTS 5.21 series (up to 5.21.5), and feature series versions (up to 6.9.0, 7.2.0). The issue has been addressed in subsequent versions of both LXD and Incus, with fixes implemented in commits a52e5d0 for LXD 5.x and 6.x, and cfd9f66 for Incus.\n\nAttackers can exploit this vulnerability by smuggling the low-level configuration directives inside instance snapshots or backup archives. Upon restoration of the modified snapshot or import of the backup, the attacker can execute arbitrary commands with root privileges on the host operating system. The exploit has been publicly disclosed, and proof-of-concept (POC) commands are available on GitHub Security Advisory.\n\nTo mitigate the risk, users are advised to upgrade their Canonical LXD or LXC Incus installations to the patched versions. For LXD 5.0 LTS environments, the upgrade should be to version 5.0.7 or later; for LXD 5.21 LTS, upgrade to 5.21.5 or later; and for LXD 6.x and Incus 7.2.0 or higher. Additionally, it's recommended to run an API audit using commands such as `lxc query /1.0/instances?recursion=2` or `incus query` to identify and remove snapshots or active configurations containing the prohibited `raw.*` directives.",
  "summary": "GHSA-47w9-6r3f-938g: Authorization Bypass and Host Root Command Execution in Canonical LXD and Incus Vulnerability ID: GHSA-47W9-6R3F-938G CVSS Score: 9.9 Published: 2026-11-06 A missing authorization and configuration validation vulnerability in Canonical LXD and LXC Incus allows authenticated users within restricted projects to bypass project security boundaries. By smuggling prohibited…",
  "key_points": [],
  "editors_take": null,
  "illustration": null,
  "coverage": {
    "outlets": 1,
    "also_reported_by": []
  },
  "ai_generated": true,
  "disclaimer": "Summaries, key points and the editor’s take are written by software from other outlets’ reporting and may contain errors — always check the linked original."
}